
 

 

DeltaV RTU Connect 
D301690X412 Getting Started

 
DeltaV RTU Connect - Getting Started  
 

Seamless connection - 

from your field assets to your plant automation system 



   DeltaV RTU Connect Getting Started

 



 

Contents i 

 
DeltaV RTU Connect Getting Started

Table of Contents 

1  DeltaV RTU Connect – Getting Started ................................................................................. 1 
1.1  Definition of Acronyms ............................................................................................................1 
1.2  What is the DeltaV RTU Connect?..........................................................................................1 
1.3  Setup Options..........................................................................................................................1 

1.3.1  Real Time Integration of Data and Alarms using the Virtual Controller ..............................3 
1.3.2  Pass-through Historization from the DeltaV Controller .......................................................4 
1.3.3  Alarm-Event Historization to the PEH using the OPC Server.............................................6 
1.3.4  Pass-through Historization plus PI Historical Backfill..........................................................7 

1.4  Installation Pre-requisites........................................................................................................8 
1.4.1  Hardware.............................................................................................................................8 
1.4.2  Software ..............................................................................................................................8 

1.5  Installation Task Flow..............................................................................................................9 
1.5.1  Install Two DeltaV Application Stations ............................................................................10 
1.5.2  Installing ROCLINK 800 and OpenBSI .............................................................................11 
1.5.3  Configuring the RTU Control Strategy ..............................................................................12 
1.5.4  Configuring NetView .........................................................................................................13 
1.5.5  Configuring Harvester .......................................................................................................22 
1.5.6  Installing OpenEnterprise Server ......................................................................................23 
1.5.7  Building the OpenEnterprise Database.............................................................................27 
1.5.8  Adding a ROC Device .......................................................................................................36 
1.5.9  Collecting Data from ROC Devices...................................................................................39 
1.5.10  Creating the FHX File....................................................................................................43 
1.5.11  Configuring the Plant Event Historian ...........................................................................47 

1.6  Licensing Information ............................................................................................................50 
1.6.1  How do I Register My Software?.......................................................................................50 
1.6.2  How to Transfer a License from One PC to another PC...................................................56 

 

 



   

Contents ii 

DeltaV RTU Connect Getting Started

 



 

 Page 1 

 
DeltaV RTU Connect Getting Started

1 DeltaV RTU Connect – Getting Started 
This document introduces you to DeltaV RTU Connect, and describes how to install and configure it. 
The relevant sections provide details on each process. You also need to consult the user 
documentation for OpenBSI, ROCLINK 800, ControlWave Designer and OpenEnterprise as you 
proceed. Firstly, we give a brief description of the DeltaV RTU Connect and outline the main 
configuration scenarios so that you can decide which of these scenarios best suits your needs. 

1.1 Definition of Acronyms 
RTU: Remote Terminal Unit with process control capabilities. In this context it specifically refers to 
ControlWave and remote operation controllers (ROCs) from Remote Automation Solutions. 

SCADA: Supervisory Control and Data Acquisition. SCADA systems typically utilize a database and 
communications software to record, display and write to process control data in remote controllers 
(RTUs). Network connection can be low bandwidth or even intermittent. In this document, SCADA 
specifically refers to the OpenEnterprise SCADA system from Remote Automation Solutions.  

OE: OpenEnterprise. 

DA: Data Access, the OPC standard for accessing real time data. 

DCS: Distributed Control System. An integrated process control solution that utilizes distributed 
hardware and software over an uninterrupted network connection. In this document, DCS refers 
specifically to DeltaV. 

1.2 What is the DeltaV RTU Connect? 
DeltaV RTU Connect acts as a portal for SCADA monitored process control data through to a DeltaV 
network. 
 
DeltaV RTU Connect incorporates the OpenEnterprise SCADA communications components 
together with the industry standard connectivity capability to propagate data through to the DCS and 
return control commands to the RTU.  
 
1.3 Setup Options 
The basic method of integrating real time data from RTUs is the same for all installations of the RTU 
Connect. However, since real time data is constantly changing, you need to historically log (historize) 
these real time values in order to be able to view the changing data as a trend. The way real time data 
is historized can differ, depending on system requirements. These historization options affect the 
components that you need to install, so we outline these options here. You can then decide which 
option best fits your project. 

1. Real time integration of Signal and Alarm-Event Data from the Virtual Controller: This 
basic RTU Connect functionality passes real-time signal and alarm-event data to DeltaV. It 
provides a common data structure for all DeltaV RTU Connect installations. See Section 1.3.1 
for details. 

2. Pass-through historization of signal and alarm-event data from the Virtual Controller: 
With this option, real time signal data passes directly from the Virtual Controller to the 
Continuous Historian, and real-time alarm data passes to the Event Chronicle on the Operator 
Workstation. Alternatively, real time signal data can pass through to a separate PI database. 
See Section 1.3.2 for details 

3. Pass-through historization of alarm-event data from the RTU Connect Alarm and Event 
OPC Server: This option passes alarm-event data the RTU raises to the Plantwide Event 
Historian (PEH) via the RTU Connect Alarm and Event OPC Server. The PEH is installed on 
a separate application station. See Section 1.3.3 for details. 
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4. Historical Backfill from the RTUs to a PI database: The DeltaV RTU Connect backfill 
service updates the PI Historian with historical data that is collected directly from the RTUs. 
This option is recommended where low bandwidth or intermittent communications with the 
RTUs is likely. It requires that you install and enable the necessary DeltaV RTU Connect 
Backfill components and install the PI Database onto a DeltaV Application Station. See 
Section 1.3.4 for details.
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1.3.1 Real Time Integration of Data and Alarms using the Virtual Controller 

This standard default mechanism propagates real time data into the DeltaV system, and it applies to 
all DeltaV RTU Connect installations. 

 

Figure 1 - Real Time Data Collection 

Data originating from the RTUs passes to the OpenEnterprise real-time database. Real time signal 
data is propagated to DeltaV through the DeltaV Virtual Controller. The OpenEnterprise DA OPC 
server supplies data to the OPC Mirror. The OPC mirror ‘pipes’ the data through to the DeltaV OPC 
server. The DeltaV virtual controller then acquires this data and makes it available to the rest of the 
DeltaV system. 

DeltaV components and licenses: 

• DeltaV Application Station software suite with the DeltaV OPC DA server, sized for the 
appropriate number of data values from OE 

• OPC Mirror, 2 server license (one server for OE, one server for DeltaV) 

• Plantwide Event Historian, 2 server license (one for the alarm & event backfill capability from 
OE and one for real-time alarms and events from DeltaV) 

RAS components and licenses: 

• OpenEnterprise software 
• DeltaV RTU Connect (the DeltaV FHX and OPC Mirror pipe configuration builder software) 
• OpenBSI license (Bristol RTU communications middleware) 
• ControlWave designer license (Bristol RTU IEC 6-1131 programming tool) 
• ROCLINK 800 license (ROC Configuration software) 
• ROC DS800 license (ROC IEC 6-1131 Configuration tool) 

 

DeltaV RTU Connect 
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1.3.2 Pass-through Historization from the DeltaV Controller 

Historical signal and alarm-event data is automatically made available to the DeltaV system from the 
real time data that is sent from the DeltaV Virtual Controller on the RTU Connect Application Station. 
Pass through historization can be implemented using the DeltaV Continuous Historian that is installed 
on DeltaV Operator Workstations or using a PI Historian that is installed on a separate Application 
Station. 

1.3.2.1 Pass-through Historization to the Continuous Historian and Event Chronicle 

Real time signal data can be passed-through from the DeltaV Virtual Controller to the native DeltaV 
historian (the “Continuous Historian”) which is based on the Emerson owned “Objectivity” database. 
This database resides on each Operator Workstation as a separate historical instance and services 
the historical data required for trending. This can be thought of as the default method of storing 
historical data for the RTU Connect.  

Alarm and Event data can also be passed through from the DeltaV Virtual Controller via simulated 
Alarm Limit function blocks. Alarms are raised from these function blocks and are collected by the 
Event Chronicle which again resides on the DeltaV Operator Workstation. 

  

Figure 2 – Pass through Historization using the Continuous Historian 

Continuous Historian installation pre-requisites 

The DeltaV Continuous Historian is part of the DeltaV installation and requires no further installation 
or licensing. It is recommended only for systems which have a continuous, robust connection to the 
RTUs. It does not allow for historical data to be backfilled from the RTUs following connection 
downtime. 

 

DeltaV RTU Connect 
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1.3.2.2 Pass-through Data Historization to a PI Historian 

Alternatively, the real time signal data can be passed-through to a PI database. This would be 
installed on a separate Application Station. 

Real time signal data within the Virtual controller can be historized using the standard DeltaV system 
historical streaming into PI from sampled real time data, via the Smart controller function. This 
scenario is shown in Figure 3. 

 

Figure 3 - PI Data Pass-Through 

Real time data is stored with the time stamp assigned by the virtual controller at the time of 
processing. Again, this method of historization does not allow for the backfilling of historical data from 
RTUs after downtime. 

The PI OPC interface is a component of the DeltaV Smart controller that facilitates data propagation 
to the PI database when a signal is configured with DeltaV to be a historically logged point. An XML 
file called the En-Hist config file is generated by DeltaV for tags that have been selected for historical 
logging. The Ent-Hist file specifies scan rates etc and is used by PI to define the historical collection. 
These functions are inherent in DeltaV/PI components and are not part of DeltaV RTU Connect 
functionality. 

PI Historian Installation pre-requisites 

OSIsoft component and licenses: 

• Enterprise PI server 

 

DeltaV RTU Connect 
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1.3.3 Alarm-Event Historization to the PEH using the OPC Server 

An alternative way of historizing alarm-event data is to pass the alarm-event data from the RTU 
Connect Alarm and Event OPC Server to the PEH, which is installed on a separate Application 
Station. 

  

Figure 4: Alarm-Event Historization to PEH 

Is Pass-through Historization Enough? 
Historization using the Continuous Historian or a PI historian alone is only recommended where there 
are permanently connected RTUs with robust communications. However, for typical SCADA 
applications, the telemetry can be intermittent and subject to outages. The pass-through historization 
approach alone would not be recommended in this case, as there is no mechanism to handle 
downtime at the device. For example, if a ROC device was configured to store historical data within its 
archive and attached to the system described above, and there was a communication outage, data 
could be lost. This is because the pass-through Historization process cannot access and back-fill the 
stored archive data in the ROC RTU captured during the period of downtime. 

 

 

 

 

 

DeltaV RTU Connect 
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1.3.4 Pass-through Historization plus PI Historical Backfill 

The pass-through Historization method defined in section 1.3.2.2 historizes the Virtual controller data 
but does not propagate the RTU time stamp or support the RTU back-fill function. The solution to this 
problem is to use the RTU Connect PI Historical Backfill Service. One version of this is shown in 
Figure 5. In this scenario, during normal operation real time data passes from the RTU Connect 
Virtual Controller directly into the PI Historian. If there is a disconnection with the RTUs, any missed 
data passes via the RTU backfill service into PI once communications are resumed. 

  

Figure 5 – Pass-through Historization plus PI Historical Backfill Service 

1.3.4.1 PI Historical Backfill Explained 

If an RTU is disconnected from the system, any subsequent updates will be stored in its historical 
archive. At some time later when the device is reconnected, the data stored in its historical archive will 
automatically be sent through to DeltaV RTU Connect. The RTU Connect Backfill service then 
propagates this data to PI, inserting new records and replacing or ignoring duplicates, depending on 
how you configure it. DeltaV can then access this historical data in PI using its suite of analysis tools 
(trending, etc.).  
 
PI Historical Backfill Installation pre-requisites 

This is the same as for the Real Time scenario, plus the following components and licenses:- 

OSIsoft components and licenses: 

• Enterprise PI server, sized for the appropriate number of historical points/tags which will be 
backfilled by DeltaV RTU Connect 

• PI SDK 
RAS components and licenses: 

• OpenBSI Harvester license (Bristol RTU history upload software) 
 

DeltaV RTU Connect 
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1.4 Installation Pre-requisites 

1.4.1 Hardware 

Devices which may be connected to the DeltaV RTU Connect Application Station: 
• ControlWave Micro  
• ROC800  

 
Recommended Operating systems 

• Windows 7 (for the DeltaV RTU Connect Application Station)  
• Windows Server 2003 (for the Application Station with PEH and PI server)  

 
1.4.2 Software 

• OpenEnterprise Server (2.83 onwards) (on DeltaV RTU Connect installation disk) 
• OPC Mirror (on DeltaV installation disk) 
• ROCLink (on ROCLink installation disk) 
• PEH OPC Server (on PEH installation disk) 
• OpenBSI (on OpenBSI installation disk) 
• PI SDK – Version 1.3 (on installation disk available from OsiSoft) 
• PI Server – Version 3.3.1.3 (on installation disk available from OsiSoft) 
• Emerson PEH – 3.1 (on PEH installation disk) 
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1.5 Installation Task Flow 

 

 

Only required if you 
want to use the PEH for 
Alarms and Events. - 
see section 1.3.3 

Only required if you 
want to use the PI 
database for historical 
backfill – see section 
1.3.4 

Only required if you 
want to use the PEH for 
Alarms and Events - 
see section 1.3.3

Only required if you 
want to use the PI 
database for historical 
backfill – see section 
1 3 4
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1.5.1 Install Two DeltaV Application Stations 

The diagram below provides an overview of DeltaV RTU Connect integration. 

 

Create two DeltaV Application Stations. One hosts the RTU Connect software and the other runs 
the Plant Wide Event and PI Historians. 

Appstation1 (DeltaV RTU Connect) 

Install the following components in the following order: 

• DeltaV Appstation - Consult the DeltaV documentation for help. 
• OPC Mirror – See the DeltaV documentation for help. 
• OpenBSI v5.8 (required when using ControlWave RTUs). 

• ROCLINK 800 (required when using ROC RTUs). 

• OpenEnterprise Server 
• PEH OPC Server – Consult the DeltaV documentation for help. 

• PI SDK (used for historical streaming) – Version 1.3 (Not supporting 1.2 or less) – 
Consult the OsiSoft documentation for help. 

 
Appstation2– (Plant Wide Event Historian & PI historian) 

Install the following components in the following order: 

• DeltaV Appstation - Consult the DeltaV documentation for help. 
• Emerson PEH - Consult the DeltaV documentation for help. 
• PI Server Consult the OsiSoft documentation for help. 
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1.5.2 Installing ROCLINK 800 and OpenBSI 

Before you can begin installing OpenEnterprise Server on your DeltaV RTU Connect Application 
Station, you need to install and configure the control strategy software. The process data is then 
available to OpenEnterprise. 

1.5.2.1 Installing ROCLINK 800 

For information on installing and configuring ROC RTUs, refer to the ROCLINK™ 800 Configuration 
Software User Manual (for ROC800-Series)” form number A6218, part number D301159X012. This 
manual is available from the Emerson documentation web site ( 
http://www.documentation.emersonprocess.com/groups/public/documents/instruction_manuals/) 

1.5.2.2 Installing OpenBSI 

When installing OpenBSI, select the following options:   

• NetView (Network Edition) 

• Harvester 

• ControlWaveDesigner with ACCOL III 

• BSIConfig 

You specify these components on the “Select Features” page of the OpenBSI installation wizard. 
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1.5.3 Configuring the RTU Control Strategy 

Configuring the RTU Control Strategy is beyond the scope of this guide, but you can get help on this 
subject from the documents listed below. Note that you must have done the following before you can 
continue configuring DeltaV RTU Connect:- 

• ControlWave RTUs: Your Control Strategy files must have been coded and saved using 
ControlWave Designer. Ensure you have saved to both MWT and ZWT format.  

• ROC RTUs: Your ROC RTUs must be configured using ROCLink™ 800. 

1.5.3.1 Configuring ControlWave RTUs 

For information on how to configure ControlWave RTUs using ControlWave Designer, refer to the 
following documents: 

• Getting Started with ControlWave Designer, (document number D5085, part number 
D301416x012)   

• ControlWave Designer Programmer’s Handbook (document number D5125, part  number 
D301426x012)  

1.5.3.2 Configuring ROC RTUs 

For information on installing and configuring ROC RTUs refer to the following document: 

• ROCLINK™ 800 Configuration Software User Manual (for ROC800-Series) form number 
A6217, part number D301249X012 from the Emerson documentation web site  
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1.5.4 Configuring NetView 

This section provides the most basic instructions for configuring NetView within OpenBSI. For more 
information on every aspect of configuration, consult the OpenBSI Utilites Manual, (document number 
D5081, part number D301414x012), available from the Emerson documentation web site. 

To open NetView:  

1. Select Start > Programs > OpenBSI Tools > NetView 

 

2. Select File > New.  

 

3. Save As Current.NDF 

 

4. Page 1 of the System wizard opens.  will see the following three wizard pages.  



   

Page 14 

DeltaV RTU Connect Getting Started

a) Page 1 

Accept the default settings on this page. 

 

Click Next . 

b) Page 2 

Accept the default settings on this page also. 

 

Click Next.to display page 3 of the System wizard.  

c) Page 3 

On this page you need to type the name of your Host PC (the NHP) and its primary IP address in 
the appropriate fields. 

 

Click Finish. 
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5. To add a network node, right-click the top node and select Add > Network. 

 

The first page of the Network Wizard opens:- 

 

 

 

 

 

Type in a name for the 
network. 

Select IP Network  

 

Click Next. 

On page 2 of the Network Wizard, the Destination IP address for Alarm and RBE reports will be 
entered automatically.  

 

Click Finish.  

6. Now you can add an RTU. In the main NetView window, right click on the new network node and 
select Add > RTU. 
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7. Accept the defaults on page 1 of the RTU Wizard.  

 

Click Next. 

8. Configure the RTU Name, RTU type and name of the Control Strategy file on page 2 of the 
wizard. 

 

Click Next. 

 

 

 

Enter a name for the RTU here 

Select the correct RTU type 
from this list 

Click Browse to find the Control 
Strategy file. It should have 
been created by this stage. 

 

Leave these other fields as they 
are. 
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9. Enter the RTU’s Primary IP address on page 3. 

 

10. Accept the defaults on page 4 and click Finish. 

 

11. Now you need to add a line. Right-click on the top node and select Add > Line. 
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12. Enter a name for the line on page 1 of the Comm Line wizard. 

 

13. Enter the first three mask values for the IP Line and click Finish. 

 

Type a subnet mask here of 
255.255.255.0. The 255 mask 
numbers force the line to connect 
to the 192.168.1 subnet IP address 
in the example here. 

The 0 (zero) value at the end of the 
mask forces the line to be open to 
all RTUs having IP addresses that 
occur within the specified subnet. 

14. When you have finished, the RTU should show a status of 0x0000, which means it is connected. 
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15. To ensure that the RTU can send Alarm and RBE to your DeltaV RTU Connect server, you may 
need to write the server’s address to the RTU’s configuration parameters. Right click on the CW1 
device and select RTU > RTU Configuration Parameters. 

 

The system retrieves the RTU configuration parameters… 

 

16. Modify the NHP IP ADDR A to be the IP address for your DeltaV RTU Connect server,  

 

 

Then click Write to RTU to download this setting to the RTU. 

 

 

 

After the new setting downloads, you may see a message dialog indicating that the RTU is being 
stopped and restarted. Click Yes to accept and close this dialog. 
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17. Select Start > Programs > OpenBSI Tools > ControlWave Tools > ControlWave Designer to 
open ControlWave Designer.  

18. Select File > Open Project/Unzip Project to ppen the Control Strategy file you want to download 
to the RTU. … 

 

Then select the MWT file… 

 

Click Open. 

19. Select Build > Make and allow ControlWave Designer to build the project. You may see various 
warning or error messages. You can ignore warnings, but you must correct any errors before the 
build can continue,  

 

 

20. Select Build > Transfer Download Files. The Transfer Project Download Files dialog displays.  
and follow the prompts to transfer the download files. 
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21. Select the Zip Project and Transfer Zip File option. Cick Transfer. 

 

22. You can now download the control strategy from NetView. Close ControlWave Designer and re-
open Netview. Right-click on the RTU node and select Download to download the control 
strategy file from the DeltaV RTU Connect Application Station to the RTU.   
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23. Type the user name and password into the relevant fields.   

 

Then click Begin to start the download. 

1.5.5 Configuring Harvester 

If you are using ControlWave RTUs and want to backfill historical data to the PI Server, you must also   
configure the Harvester utility. For information on doing this, please refer to the OpenBSI Harvester 
Manual (document number D5120, part number D301421X012) avallable from the Emerson 
documentation web site. 

The Harvester uses a utility called “Converter”. Instructions on how to use the “Converter” application 
are also found in the “OpenBSI Harvester Manual”. Later, when OpenEnterprise Server has been 
installed on the DeltaV Application Station, the OpenBSI Converter application will need to be pointed 
to the OEBACKFILL DLL file. For instructions on doing this, refer to the  the following document: 
NW3000 Archiving Overview (document number D5092, part number D301506x412) available from  
the Emerson documentation web site. 

 

 

 

 

 

 

 

 

 

 

 

http://www.documentation.emersonprocess.com/groups/public/documents/instruction_manuals/d301421x012.pdf�
http://www.documentation.emersonprocess.com/groups/public/documents/instruction_manuals/d301421x012.pdf�
http://www.documentation.emersonprocess.com/groups/public/documents/instruction_manuals/d301506x412.pdf�
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1.5.6 Installing OpenEnterprise Server 

This section details the installation process for installing the DeltaV RTU Connect. Before doing this, 
you should have already done the following: 

• Installed the RTU configuration software:- 

o OpenBSI if you are using ControlWave RTUs 

o ROCLINK 800 if you are using ROC RTUs 

• Created the control strategies for each RTU (and downloaded to the RTU if using 
ControlWave RTUs) 

• Configured NetView and Harvester if using ControlWave RTUs 

Place the OpenEnterpriseV2.83 installation disc into the host machine’s DVD\CD drive. If the 
installation does not run automatically, open the disc in Windows Explorer and double click on the 
OpenEnterprise.exe file. 

1.5.6.1  Preparing Setup Dialog 

The first dialog in the Wizard shows the InstallShield wizard preparing the host machine for the 
installation. A blue bar informs you of progress. It is possible that this dialog opens at first behind the 
Main Installation dialog. To bring it to the forefront, click on it.  

 

When preparation has finished, the Welcome Dialog opens automatically. 
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1.5.6.2 Welcome Dialog 

This dialog displays a 'Welcome' message.  

 

Click Next. The License Agreement dialog displays. 

1.5.6.3 License Agreement 

Next is the License Agreement dialog.  Read through the terms of the License Agreement. You must 
select the “I accept the terms of the license agreement” button in order to enable the Next button. 

  

Click Next when you are ready to continue. The Destination Location dialog displays. 
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1.5.6.4 Destination Location 

This dialog displays the installation directory.  The default installation directory is  ‘C:\Program 
Files\Bristol\OpenEnterprise\’ Click Change to select a different install location, if required.  

 

Click Next. The Select Components page displays. 

1.5.6.5 Select Features 

On the Select Features page, select the OpenEnterprise Server option:   

 

Click Next. The Ready to Install the Program page displays.  
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1.5.6.6 Ready to Install 

The Ready to Install the Program’ dialog  gives you the opportunity to revise the installation details by 
clicking Back.   

  

Click Install to begin the installation and display the Setup Status screen. 

1.5.6.7 Setup Status 

The Setup Status screen shows the progress of the installation. Leave it running until the final 'Install 
Wizard Complete' dialog displays.  
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1.5.7 Building the OpenEnterprise Database 

After you install OpenEnterprise Server, you must build the OpenEnterprise database using the 
Database Project Builder. This creates all the tables required to run OpenEnterprise. If you are using 
ControlWave RTUs the Database Project Builder can automatically insert the signals from your 
control strategy files into the database. 

1.5.7.1 Starting the Database Project Builder 

Click the Windows Start button and select the following shortcut:- 

Start>Programs>OpenEnterprise>Administrative Tools>Database Project Builder 

 

1.5.7.2 The Database Project Builder Wizard 

The Database Project Builder (DPB) Wizard completes 12 steps which result in the building of an 
OpenEnterprise project specific database.  You will be able at every stage before the actual build is 
initiated to go back to any of the pages and make changes.  

The Database Project Builder Wizard makes it easy for you to decide on the major configuration 
factors involved in building an OpenEnterprise project database, such as security structure and 
privileges, time zone, device drivers, and the location of the database files. 

1.5.7.2.1 Welcome 

The Welcome Page is the first page of the Database Project Builder wizard.  

 

Click Next to begin.  
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1.5.7.2.2 Location 

This page enables you to choose the directories where the database and its related files will be 
placed. OpenEnterprise suggests default directories, which are shown in the example below.  

 

 

 

 

You can use the default 
locations or change them by 
selecting the buttons on the 
right of each field and 
changing the location 
directories.  

 

When you are ready, click Next. If you specified directories which are not yet created, Project Builder 
asks you to confirm that you want it to create those directories before moving on. 

1.5.7.2.3 Database Privileges 

Use the Database Privileges page to select the default table access level for the OpenEnterprise 
application.   

 

 

 

 

 

Accept the default option of 
Open to begin with. The 
database security level can 
be changed later.  

 

Click Next to proceed.  
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Security and OpenEnterprise Documentation 

For more information on OpenEnterprise security, see the OpenEnterprise Security Configuration and 
Security Group Privileges help files, which you can find by selecting Start > Programs > 
OpenEnterprise > Documentation once you have installed OpenEnterprise.  

1.5.7.2.4 Security Groups 

This page enables you to choose whether to automatically set up groups of users or to set up the 
database with no groups of users.   

 

 

 

Leave the default “Include the 
Standard Security Groups” box 
selected. 

Click Next. Prior to the display of the next page, a message appears informing you that the default 
Administrator user (SYSTEM) has been created, along with the SYSTEM user's password. Click OK 
to accept and clear this message. 

1.5.7.2.5 Users 

The Users page enables you to define users who can log on to the new OpenEnterprise system. You 
do not need to create other users at this time.  

 

Click Next. 
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1.5.7.2.6 Time Zone 

Use this page to choose the correct time zone setting for the OpenEnterprise project.   

 

The system selects the local time zone by default. Click Next to proceed.  

1.5.7.2.7 Device Drivers 

The Device Drivers page enables you to select the required device drivers. As necessary, select the 
“Network 3000 and ControlWave Driver” or the “ROC Driver” option. You do not need the “OPC 
Driver” option for DeltaV Connect. 

 

Click Next.  
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1.5.7.2.8 Summary 

The Summary Page summarises all the options you have chosen.  Read it before you continue to 
ensure the options are correct.   

 

Click Next to proceed.   

1.5.7.2.9 Build 

The Build page informs you of the progress of the build and display any errors encountered during the 
build process.  During the build process, you may see messages warning you that Windows is 
blocking an application, and asking if you want to “unblock” it. This is normal; you should accept the 
unblock request. The build may take several minutes to complete. 

 

When the build completes, the program enables the Next button, Click it to proceed,  
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1.5.7.2.10 Signal Data 

The Signal Data page of the Database Project Builder wizard enables you to import ControlWave 
signal data into the database. At this stage, you should have created and downloaded the control 
strategy to your ControlWave RTUs. You should have also configured NetView, and it should be 
running. If you are using ROC or FloBoss RTUs, leave the “Import Signal Data” box unchecked. 

 

 

 

If you are using 
ControlWave RTUs, select 
the “Import Signal Data” 
check box 

Then click Import. 

 

If you click Import, the Database Project Builder first determines if OpenBSI is running. If not, it 
prompt you to start OpenBSI. You must then select the appropriate NDF file. The DPB then runs the 
NW3000 Database Builder to import the signals and finally prompts you to create  templates. Affirm 
that you do want the templates.The DPB then runs the NW3000 Template Builder. Click Next to 
proceed to the next page. 

1.5.7.2.11 Database Size 

Use the Database Size page to extend the size of the database and accommodate estimated future 
requirements. In the example below we have indicated that the data file should allow importation of up 
to 1000 analogs and 1000 digitals. The size can be adjusted later also. 

 

Click Next to proceed.. 
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1.5.7.2.12 Historical Data 

 

You do not need to configure any OpenEnterprise historical logging, so just click Next to proceed to 
the Session Page. 

1.5.7.2.13 Session Page 

The OpenEnterprise database cannot acquire RTU data on its own. It requires communications 
programs to run alongside it on the server. These programs acquire data from the connected RTUs 
and pass the data into the database. These Realtime Device Interfaces (RDI) communications 
programs are crucial to an OpenEnterprise system. Additionally, other software programs (such as 
the “Calculation Server” which provides internally calculated data to any clients requiring it) may run 
alongside the database. This dependence between the database and its ancillary tasks gives rise to 
the concept of an OpenEnterprise “Session”.  

The “Session Manager” manages the database and its ancillary tasks. Use this page and the next 
page of the wizard to create an OpenEnterprise “session”. You only need the ControlWave and ROC 
RDIs to be running alongside the database as part of the session, but you still need to create a 
session using these two pages. In the example below we have changed the default session name to 
“RTUConnect”. You may choose to give it another name, or to just accept the default name of 
“MySession”. Note: do not use spaces when entering a name.  

 

Accept the other default selections on this page and click Next.  
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1.5.7.2.14 Session Tasks 

The Session Tasks page enables you to select the tasks that you want to run as part of your 
OpenEnterprise session. The system selects a default set of tasks based on selections from previous 
pages in the wizard, but you can edit these selections.  

 

Remove all tasks from the Selected Tasks list. Then move the Database, RDI3000 and ROC Driver 
over to the Selected Tasks list as shown in the example below.  

If you are going to use historical backfill with the PI Server, you also need to add the Harvester, 
Converter and History Export tasks (highlighted below) to the Selected Tasks list.  

 

When you have selected the necessary tasks for your session, click Next. 
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1.5.7.2.15 Ready to Copy 

The Ready to Copy page informs you that the database build is complete and ready to be copied into 
the database folder you have identified.  

 

When you click Next, the system copies the database project over to the specified project directory. 
When the copy completes, the Finish button activates. Click it to exit the wizard and immediately start 
the session.   
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1.5.8 Adding a ROC Device 

Before you can add ROC devices to the OpenEnterprise database, you need to have built the 
database using the Database Project Builder (see the Building the Database section). ROC Devices 
and signals are added to the OpenEnterprise database using the ROC Tools utility, found in the 
OpenEnteprise Toolbox. If you are not using ROC RTUs, you can ignore this section of the document. 

1.5.8.1 Starting the ROC Configuration Tool 

The ROC Configuration Tool is part of the OpenEnterprise Toolbox. To open the Configuration Tool:   

 Select Start > All Programs > OpenEnterprise > Toolbox 

The system prompt you to log in. Log in as the default SYSTEM user. 

Double-click the ROC Tools icon:   

 

The ROC Tools User Interface displays.  

 

1.5.8.2 Adding a ROC Device connected via IP 

Make sure you can connect to the ROC with ROCLINK. Close ROCLINK. Make sure the ROC RDI is 
running. 

1. Select Tools > New Device > From Connected Device from the main menu bar of the ROC 
Configuration Tool.  
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The Device Configuration wizard opens.  

2. On the General Page, enter options required. At a minimum, enter a name for the device and 
the ROC Address and Group. Note that the name you enter forms part of the signal (tag) 
name. Because the DeltaV system has a 16 character maximum signal name length, it’s 
advisable to enter a short name (up to five characters) for the device.  

 

Click Next to proceed. 

3. On the Communications Routes page, enter options required, as a minimum enter the IP 
Address (or network name e.g. as resolved by HOSTS file) and port number.  

 

Click Next to proceed,  

4. On the Override Driver Defaults page, enter any options required or accept the defaults. You 
can accept the defaults, shown in the image below. 
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Click Next  to proceed. 

5. On the Points Selection Page, select required options. You can accept the defaults, as shown 
in the example below. 

 

Click Finish. The system adds the device to the database. 
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1.5.9 Collecting Data from ROC Devices 

Follow the instructions below to configure signal, alarm and event data collection from ROC Devices 
using the ROC Configuration Tool.  

1.5.9.1 To configure collection of analog and digital value data every 10 seconds 

1. Expand the device required from the tree view.  

 

2. Right-click Requests by Schedule and select New Data Collection (General). The Request 
Configuration – General screen displays. ' 

 

3. Enter a description (such as Collect Analog and Digital Values) and select 10 Seconds from 
the dropdown list for the Schedule field. Click Next. 
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4. Select Pattern: Values from the drop-down menu for the Point Parameters field’. 

 

5. Select Multiple Types from the Point Type Selection field. 
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6. Select point types required (AIN and DIN) 

 

7. Click Finish.  

1.5.9.2 To configure scheduled collection of alarms  

1. Expand the device required from the tree view. Expand the Requests by Type and General 
selections. Right-click on ReadAlarmData. Select Properties from the displayed menu.  
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2. Select the desired schedule from the drop-down list.  

 

3. Click OK. 

1.5.9.3 To configure scheduled collection of events  

1. Expand the device required from the tree view. Expand the Requests by Type and General 
selections. Right-click Read Event Data and select Properties from the displayed menu. 

 

2. Select the desired schedule from the drop-down list. 

3. Click OK. 
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1.5.10 Creating the FHX File 

The following instructions provide the basic steps by step directions. For more details on configuring 
Tag Formats and Alarm Associations, refer to the DeltaVConnect help file. The same information can 
also be found in Chapter 11 of the DeltaV RTU Connect Reference Guide, (Document Number 
D301682X412). 
 

1. Open the DeltaV RTU Connect Export Tool 

a. Select Start > All Programs > OpenEnterprise > Toolbox. 

b. Double-click the DeltaV RTU Connect Export tool within the Toolbox. 

2. Configure the DeltaV tag format that you want to use 

a. Select Tools > Properties. 

b. Select the Tag Format page and configure the tag formats. The defaults are typically 
sufficient for a ROC or FloBoss device. 

 

3. Configure the Alarm Associations that you have used.  

a. Select Tools > Properties 

b. Select the Alarm Association page and configure the alarm associations that you 
have used. The defaults are typically sufficient for a ROC or FloBoss device. 
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4. Use the Search Criteria Controls on the main UI to create a list of the signals you want to 
export to DeltaV.  

 

5. Drag and drop the signals to the DeltaV Explorer pane.  
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a. If any signal names need changing, the Name Change buttons become enabled: 

 

b. The Status Pane informs you that some signals require a name change: 

 

You can change the names one at a time by clicking on the Name Change buttons, or 
using the left and right cursor keys on the keyboard to scroll up and down the DeltaV 
explorer pane. Only tags requiring a name change are selected each time you click a 
button or a cursor key. You can then change the name of the selected signal.  
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6. When ready, click Export at the top of the DeltaV Explorer pane.  

 

The DeltaV RTU Connect configuration tool creates a .FHX file that DeltaV recognizes as a 
control strategy file. 

You now need to download the FHX file to your virtual controller:  

1. Import the FHX file in DeltaV Explorer, assign modules and download 

2. Stop and start the OPC Mirror 
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1.5.11 Configuring the Plant Event Historian 

Once you have installed the Plant Event Historian (PEH) on Application Station #2, you need to set 
the system up to use the Alarm and Event (A&E) OPC server on the RTU Connect Application Station 
(which we call Application Station #1).  

1. Ensure the Plant Event Historian OPC server has already been installed on the RTU Connect 
Application Station (Application Station #1). 

2. Access Application Station #2 and open the PEH Configuration tool. 

3. Configure the PEH OPC Server Startup File to be the RAS Alarm and Event OPC server that is 
on the RTU Connect App Station (Application Station #1). The server name displays as 
“BristolBabcock.BristolOPCEventServer” in the list of available OPC servers on the RTU Connect 
machine. 

4. Return to the RTU Connect Application Station (Application Station #1) and configure the A&E 
OPC server to start under the credentials of the Administrator user: 

a. Open the Control Panel. 

b. Select Administrative Tools. 

c. Select Component Services. 

d. In the DCOM Config folder, right-click on the BristolBabcock OPC Event Server and 
select the Properties option from the context menu.  

 

e. Select the Security tab. 
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f. Select Use Default in the Launch and Activation Permission frame.  

g. Select Use Default in the Access Permissions frame.  

h. Select Customize in the Configuration Permissions frame.  

i. Click Edit to display the Change Configuration Permissions dialog.  

 

j. Add Full Control and Read permissions to the Administrator user name.  

k. Click OK, The Server Properties dialog displays.  

l. Select the Identity tab.  
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m. Select the “This User” option and add the local Administrator with username and 
password. 
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1.6 Licensing Information 
Upon initial installation, the OpenEnterprise RTU Connect software package operates for a 30 day 
evaluation period. Each time you start the software the system displays a reminder message telling 
you that the software is a demo version, and shows you a count of the number of days remaining in 
the trial period. During this trial period, you can continue to run the software without registering. 

 

 Caution 
At the conclusion of the 30-day evaluation period, the OpenEnterprise RTU 
Connect software package ceases to function. You will see the following        
message:- 

 

You MUST register the software package in order to use it after 30 days. Do 
NOT attempt to set back the date on your computer in order to extend the 
evaluation period; doing so disables the software and terminates the 
evaluation period. 

 
1.6.1 How do I Register My Software?  

1. Ensure that the computer has an active Internet connection.  

Note:  If this computer does not have an active Internet connection, you will need access to a 
computer which does, and you will need a USB thumb drive (or other method) to transfer the 
license file between the Internet-connected computer, and the computer on which you have 
installed the software. 

2. Start the License Manager software, on the computer containing the newly installed software 
packages, using the sequence: Start > Programs > Bristol Babcock Licensing> License 
Manager. 

3. The License Manager examines your PC, and identifies in a list, which OpenBSI / OpenEnterprise 
software packages are installed on this computer. Any package that is not registered shows as 
Trial in the State field. Click Create LRF to generate a License Request File (*.LRF) and save the 
file on your PC. Leave the License Manager session running. 

Note:  Make note of where on this computer you save the LRF file, because you will need it later. 
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4. Click Get Key, and your Internet browser brings you to the Software Registration area of the 
Emerson Remote Automation Solutions website. Alternatively, in your browser, go to: 

http://www2.emersonprocess.com/en-
US/brands/remote/systems_and_software/supportnet/Pages/license_registration.aspx 

Note:  If this computer does not have internet access, transfer the *.LRF file you just created to a 
computer which does have internet access. You might need to copy it to a CD, use a USB thumb 
drive, or transfer it by other means. Once you load it onto the other internet-capable computer, 
use the URL in step 4 to proceed with the registration. 

 

This list shows the 
software packages 
currently installed on 
this computer and their 
licensed status 

Click Create LRF

http://www2.emersonprocess.com/en-US/brands/remote/systems_and_software/supportnet/Pages/license_registration.aspx�
http://www2.emersonprocess.com/en-US/brands/remote/systems_and_software/supportnet/Pages/license_registration.aspx�
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5. Enter your Customer Id and Password and click Sign-On. 

Note:  You can find the Customer Id and Password on a label affixed to the outside of your 
OpenBSI / DeltaV RTU Connect CD-ROM package.  

6. Now you have two options. You can view which licenses have been purchased and are available 
for you to register, or you can skip that step and proceed to register your software. To view the 
available licenses, go to step 7. To register the software, skip to step 8. 

   

 

7. To view which software packages have been purchased for this particular Customer Id number, 
as well as how many of those licenses are already in use, click the View link. The View Software 
Licenses page opens. You may need to use the scroll bar to locate the product you want to view. 
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Field  Desciption 
Product Name This displays the name of the software packages for 

which licenses have been purchased using your 
Customer Id number. In addition to OpenBSI 
packages other software products such as 
OpenEnterprise packages are displayed. 

Available This displays the number of licenses out of the total 
number purchased which have not been registered 
for use. If the Available number is 0, you cannot 
register a new copy of this particular package. 

Quantity Ordered This displays the total number of licenses purchased 
using this Customer Id number. 

Options Any options available (such as being able to update 
the information displayed) will be shown here.  

 

8. To register your software, click the Register link. The Registration Information page opens. 
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9. Enter your name in the Your Name field, and your e-mail address in both the E-mail Address 
and Verify E-Mail fields. Then use the Browse button to locate the license request file you 
generated previously in Step 3. Finally, click Next. The Unlock Software Licenses page opens. 

Note: The website will send you an e-mail with an attached unlock key file to the e-mail address 
you specify here. 

10. Click the Unlock checkbox for the product(s) you want to register, then click Submit License 
Request to send the license request to the website. 

 
  

 

11. If the license request is successful, the website generates a key file you can use to unlock your 
software. Click Key file to download a copy of the key file. (The website also e-mails you a copy 
of the key file at the e-mail address you entered in step 9.) 

Note:  If the computer which contains the locked software does not have internet access, you 
need to transfer the key file back to that computer to complete the registration process. 

 

12. In order to complete the registration process, the key file you received must reside on the PC 
containing the newly installed software packages. Go back to the License Manager session you 
started in Step 3. (If you shut the License Manager down, restart it by clicking Start > Programs 
> Bristol Babcock Licensing> License Manager.  

13. To apply the key file, click the Include Key button and specify the location of the key file. 
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14. If the registration completes successfully, you will see a message box. Just click OK and you’re 
done. Reboot your PC for the new licenses to be activated. 
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1.6.2 How to Transfer a License from One PC to another PC 

Occasionally, it may be necessary for you to transfer an OpenBSI software license from one 
computer, to another computer. This might be necessary, for example, if you are upgrading to a 
newer computer, and want to shift your OpenBSI license to the newer computer, and remove it from 
the older computer. 

In this explanation, the computer which is giving up its license will be referred to as the source 
computer and the new computer which will receive the transferred license will be referred to as the 
destination computer.  

Note: In order to transfer the license, the license on the source computer must already be 
registered, and the software must have already been installed on the destination computer. 

 
1. Start the License Manager software, on the destination computer, using the sequence: Start > 

Programs > Bristol Babcock Licensing> License Manager.  

2. Select the unlicensed package you want to change from a trial / demo package, into a licensed 
package, and generate an empty transfer request file. 

Note: The transfer request file you create must be read-write. It cannot be a read-only file. 

 

3. Answer Yes to the prompt.  

 

First, select the 
unlicensed 
package for 
which you want 
to obtain a 
license for from 
another 
computer. 

Then click Create 
Transfer
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4. Save the empty transfer (*.XFR) file.  

 
 
5. Click OK when the file is created. 

 

 
  

 
6. Copy the XFR File you just saved onto the source (licensed) computer. You can transfer it via a 

USB thumb drive, e-mail, etc. 

Start the License Manager software, on the destination computer, using the sequence: Start > 
Programs > Bristol Babcock Licensing> License Manager.  

7. Now, you must transfer the license of the software package, into the transfer (*.XFR) file you 
created in Step 5. In the License Manager, select the license you want to transfer and click 
Transfer License. 

8. Now locate the XFR file you created earlier and click Open. 

Click Yes. 

Click Save 
to create the 
empty 
transfer file. 

Click OK. 
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Click on [OK]

Open the XFR file you created earlier

 
9. When the License Manager completes the update of the XFR file, click OK. You now have 

successfully removed the license from the source computer, and stored it in a file. Notice now 
that the State field in the License Manager on the source computer no longer shows “Licensed” 
for this software package. 

 

10. You can now copy the XFR file onto the destination computer. (You can transfer it via a USB 
thumb drive, e-mail, etc.) 

11. Once you copy the XFR file to the destination computer, you can install, and complete the 
transfer. To do this, select the package which needs to be licensed, then click Install Transfer.  
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12. The License Manager prompts you to confirm you want to install the transferred license. Click 
Yes. 

 

13. Specify the location of the updated XFR file on the destination computer and click Open. This 
completes the transfer. 

Select the package 
you want to license, 
then click Install 
Transfer 
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