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B.1.1 Using the FST Editor 
Using the FST Editor, you create, compile, debug, and download FSTs 
to the device. The FST Editor consists primarily of a workspace and 
menus, similar in structure to spreadsheet programs. The FST Editor 
also allows you to monitor and trace of an FST while it runs. 

Select Utilities > FST Editor or click the FST Editor button ( ) to 
launch the FST Editor. The FST Editor screen displays.  

 
Figure B-1. FST Editor 

The FST Editor provides a workspace, menus, and buttons for creating a 
Function Sequence Table. The title bar at the top of the workspace 
window identifies the FST being created or edited.  

The workspace area is a table, divided into rows and columns with the 
intersection called a cell. Cells are denoted by a box containing the 
cursor and a gray line around the cell. Use Tab and the arrow keys to 
move between cells, or you can go directly to a cell by clicking it with 
the mouse.  

The Header Line of the workspace contains the function structure 
column names. The STEP column contains the numbers that correspond 
to the number of rows or steps available in the workspace.  

The LABEL, CMD, ARGUMENT1, and ARGUMENT2 columns 
correspond to the structure of the functions. The Comment column 
allows you to insert comments about the FST.  

Note:  Comments are not downloaded (sent) to the FB107; they are only 
included in the FST when you save it to a file.  
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Table B-2. Workspace and Output Keystrokes 

Key Action 
→ Move cursor to the right cell or character. 

← Move cursor to the left cell or character. 

↑ Move cursor to the cell above it. 

↓ Move cursor to the cell below it. 
Backspace Delete the previous character. 
Ctrl + Home Move cursor to top left cell of Workspace. 
Ctrl + End Move cursor to bottom right cell of Workspace. 

Delete Delete character in front of the cursor position. 
End Within a cell, move cursor to the right-most position within the cell. 

Within a row, move cursor to the right-most position in the row 
Enter Process saves contents of cell entry and moves to the next cell. 
Esc Undo entry and display original or prior contents of the cell. 
F1 Help. 

Home Within a cell, move cursor to the left-most position within the cell. 
Within a row, move cursor to the left-most position within the row. 

Page Down Display next page of Workspace. 
Page Up Display previous page of Workspace 

Tab Move to the next cell. 
 

FST Function 
Structure 

Each function consists of a STEP number, a LABEL (optional), a 
command (CMD), and up to two arguments (ARGUMENT1 and 
ARGUMENT2). See Table B-3. 

Table B-3. FST Function Structure 

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2 
0     

The FST program automatically provides the step numbers for each 
FST. You complete the other fields in the structure to build a function. 

Note:  Do not skip any steps. The FST program treats a blank step as 
the end of a program and does not compile correctly. 

B.1.2 FST Label Field 
The optional Label field allows you to uniquely identify a function. A 
label consists of up to six alphanumeric characters in any combination. 
A common practice is to use the label to identify the action the function 
performs. For example, the label “PUMPON” describes a function that 
activates a pump. 

Note:  Do not use the names of commands as labels.   
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Labels enable branching, the ability to direct the execution to a function 
other than the next function in the sequence. Table B-4 shows an 
example of branching. Step 0 instructs the program to GO to the label 
PMPOFF, as established by Argument 1 in step 0. The program then 
branches to step 2, where the LABEL PMPOFF is located, and performs 
that function.  

Table B-4. FST Label Field 

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2
0  GO PMPOFF  
1 PUMPON DO DOU 4-1 1 
2 PMPOFF DO DOU 4-2 0 

B.1.3 FST Command Field 
The FST command (CMD) field specifies the action a function takes.  
Each command cell provides a drop-down list that shows the function 
commands and provides a brief description of how they operate on the 
RR, CF, and Argument values. You can also type commands directly. 
Table B-5 shows the use of the GO command. Refer to Table B-9 for a 
summary of each command.  

Table B-5. FST Command Field 

STEP LABEL CMD ARGUMENT 1 ARGUMENT 2 
0  GO PMPOFF  
 .    
 .    

12 PMPOFF VAL 3  

B.1.4 FST Argument Fields 
Depending on the command, arguments can be unused, references to 
parameters in the FloBoss (TLPs), numerical constants, or ASCII 
characters.  
Once you select a command, the argument cell requires that you either 
typing a numerical constant or ASCII text or click the TLP button for 
data selection.  
Depending on whether you have selected TLPs to display as numbers or 
as text (via Tools > Options in ROCLINK 800), the TLP appears in the 
argument cells as a number sequence or as a text abbreviation of the 
Type, Point number and Parameter.  
For example, the text abbreviation of the status parameter of discrete 
input module 4 channel 1 would be DIN4-1,STATUS. The Data #3 
parameter for softpoint 3 would be SFP 3,DATA3. 
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B.1.5 FST Comment Fields 
Use the Comment field to enhance readability and provide a place to 
document the purpose of an FST, Step, group of Steps, and save 
information within the FST. Comments are discarded when an FST is 
compiled and downloaded to the device. Comments remain with the 
FST when it is saved to a disk file. 

FST Function 
Examples 

A function consists of a command, its associated arguments, and an 
optional label. In the example shown in Table B-6, the Value (VAL) 
command in Step 0 writes the current process value of analog input 
(module 3, channel 1) in EUs to the Result Register (RR), which is 
implied. The label in this example (CKHIAL) serves only as a 
comment, since no other function branches to it. 

Table B-6. FST Function Examples 

STEP LABEL CMD ARGUMENT1 ARGUMENT2 
0 CKHIAL VAL AIN 3-1,EU  
1  >= AIN 3-1,HIAL PUMPON 

In this example, when the RR value from step 1 equals or exceeds (>=) 
the High Alarm value (VAL) in step 2 and the High Alarm limit 
(HIAL) condition is met, the FST branches to the PUMPON label to 
turn the pump on. 

Note:  Refer to the FST User Manual (Form A4625) for additional 
examples. 

Basic Rules for 
Creating FSTs 

You should be aware of several rules when creating FSTs.  

 An END command is required at the end of every FST. The END 
command tells the FST to return to the top of the first step and begin 
to run from the first line at step 0 or to the step where the FST 
begins. However, you can use a branching function to force the FST 
to immediately return to step 0 if you do not want to wait for the 
next execution cycle to begin. If an END command is not present, 
the FST Editor automatically adds the END command when 
compiling. 

 The first blank line found in an FST is automatically converted to 
the END command. Any commands following a blank line are lost.  

 Each FST can have only one END.  
 Avoid internal loops and direct the program flow to the END 

Command. Use Wait states (WT command) to suspend operation of 
the FST whenever possible to reduce MPU processor overload, 
especially in a loop in which a condition is being repeatedly 
checked. 

 Configure the I/O parameters before referencing them in an FST. 
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 When using any branching command (GO, <, >, <=, >=, ==), make 
sure that you have defined the label that the command references.  

B.1.6 FST Storage and Restart 
This section details what FST configuration data is stored when a write 
to Internal Configuration Memory (EEPROM) is performed, and what 
happens to the FST after a Cold Start, Warm Start, or after upgrading 
the FloBoss firmware. 
 Write to Internal Config Memory – FSTs are permanently saved 

to memory. 
 Warm Start – If an FST is saved to memory and it is active 

(running) when a restart occurs, FSTs automatically restart at the 
beginning STEP.  

 Cold Start – On a Cold Start, FST Registers will be cleared, but 
will be restored from Internal Config Memory if valid. However, if 
you perform a “Cold Start & Clear FSTs” or a “Cold Start & Clear 
ALL” type of Cold Start, the FSTs are permanently cleared from 
Internal Config Memory. 

 Upgrading Firmware – If an FST is saved to memory and it is 
active (running) when a firmware upgrade occurs, FSTs will be 
turned off and need to be MANUALLY restarted. 

B.1.7 Creating an FST 
You can create an FST either by entering the steps in a blank workspace 
or by editing an existing file from a device or from a disk file.   

To create an FST while on-line with an FB107:  

1. Start the ROCLINK 800 software and connect to the device.  

2. Select Utilities > FST Editor. 

3. Select the tab of the FST (FST 1 through FST 6, depending on the 
device). 

4. Fill in each step with the appropriate labels, commands, tags, and 
arguments.  

 When you select the Command field, the  button appears. 
Click this button to display a list of commands from which to 
choose. Alternately, you can type the three-character command 
in the Command field.  

 Depending upon which command you choose, the argument 
fields prompt you to type in a label, choose a TLP, or enter some 
other data. 

 The Label field is optional, but are may be required if you are 
using a label within a command. Enter all required labels to 
prevent a compile error. 

 Place an End command at the end of your FST. 
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B.1.8 Creating an FST from an Existing File 
Use the following steps to create an FST by editing an existing FST. 
You may use either a FST from the device or a FST file on your PC.  

If you are using a file from the device, connect the FB107 to the 
computer running ROCLINK 800 software. 

1. Select Utilities > FST Editor. 

2. Select File > Read > From File or File > Read > From Device. 

3. Open an existing FST file with the .FST extension. 

4. Edit each step with the appropriate command, label, and arguments.  

 The Label field is optional, but are may be required if you are 
using the label within a command. Enter all required labels to 
prevent a compile error. 

 When you select the Command field, the  button appears. 
Click this button to display a list of commands from which to 
choose. Alternately, you can type the three-character command 
in the Command field.  

 Depending upon which command you choose, the Argument 
fields prompt you to type in a label, choose a TLP, or enter some 
other data. 

 Place an End command at the end of your FST.  

B.1.9 Compiling to Build and Viewing an FST 
To build and compile an FST:  

Select FST Build > Compile or click Build. 

The compiled file displays in the Output FST field. If invalid points 
exist in the FST during compilation, you receive an error indicating 
which Point Number is missing.  

Note:  If an error occurs during the compile process, the Output field 
lists the error type and the cell in question turns red. Correct all 
errors and recompile. 

Compile errors occur when you:  
 Enter invalid arguments or commands in the FST.  
 Perform a compile. The error displays in the Output field. 
 Open an FST from a FloBoss or disk file. 

B.1.10 Downloading the FST to the FloBoss 
To download the FST to FloBoss memory: 

1. Click Download on the toolbar or select File > Download.  



ROCLINK 800 User Manual (FB107) 

Issued Jan-08 FST Editor B-9 

2. If the FST currently loaded is operating, you will be prompted to 
stop the FST and continue with the download or to stop the FST 
without downloading. 

3. Enter the Version number and Description of the FST, for later 
identification, and click OK.  

Note:  This step is not required, but is extremely helpful when you 
need to identify or debug your FST.  

Following the download, you will be prompted to start the FST or you 
can start the FST in Monitor Mode or the FST Register screen. To 
verify the FST logic, you may desire to start the FST in Trace Mode. 

B.1.11 Saving an FST 
To save the FST as an individual disk file: 

1. Select FST > Save as or click the Write to file button in the FST 
Editor (see Figure B-1).  

2. Enter the File name and click Save. The FST file will be saved with 
an .fst extension. 

 

 
Figure B-2. FST Editor Toolbar 

B.1.12 Starting the FST 
Once an FST is compiled (Build > Compile) without errors and is 
downloaded to the FloBoss, you must start the FST before it can run.   

1. Connect the FloBoss to the computer running ROCLINK 800. 

2. Select Configure > Control > FST Register. 

3. Select the desired FST from the drop-down list box.  

4. Select the Status Enabled radio button. 

5. Click Apply and click OK. 

B.1.13 Stopping an FST 
To stop the execution of an FST:  

1. Connect the FloBoss to the computer running ROCLINK 800. 

2. Select Configure > Control > FST Register. 
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3. Select the desired FST from the drop-down list box.  

4. Select the FST Status Disabled radio button. 

5. Click Apply and click OK. 

B.1.14 Deleting an FST using Clear 
To permanently delete an FST: 

1. Select FST > Clear. 

2. Select the desired FST (FST1 to FST4). 

B.1.15 Reading an FST From Device 
The FST menu allows you to select FSTs to Read. 

 
Select FST > Read > From Device to retrieve the contents of 
the FloBoss memory and load the FST in the selected 
Workspace.  

B.1.16 Reading an FST From File 
The FST menu allows you to select FSTs to Read. 

 
Select FST > Read > From File to retrieve the contents of a 
disk file and display the FST in the selected Workspace.  

 Notes:  
 If invalid points exist in the FST, you receive an error 

indicating which Point Number is missing. 
 The Output view is populated with data when a Compile 

operation is performed or when an FST is read from the 
FloBoss.  

B.1.17 Closing an FST 
Select FST > Close to exit the FST Editor or Monitor screen.  

B.1.18 Printing an FST 
In the FST Editor, select FST > Print Preview to print an FST or export 
it to a file. A printed FST can help you in troubleshooting. 

When the Print Preview screen appears, click the Print button to send 
the FST to a printer. You may also select the PDF, Excel, or RTF 
buttons to export the FST as a file in those formats. 

B.1.19 Altering an FST Menu 
The FST Editor Edit menu provides options for altering a FST.  
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Select Edit > Insert Step to place a blank line in the Workspace 
before the current line. Use this option to add a function between 
two existing functions.  

 
Select Edit > Delete Step to delete the current line from the 
Workspace.  

 
Select Edit > Erase Workspace to erase the contents of the 
current Workspace permanently. You can save the FST to a file 
before you erase the Workspace.  

 

 Caution Avoid using the Windows Cut (Ctrl+X), Copy (Ctrl+C), and Paste (Ctrl+V) 
commands to manipulate text in the FST Editor. Also, be aware that the 
FST Editor does not insert but OVERWRITES existing fields.   

 
Monitor and Trace are two additional modes of operation for the FST 
Editor. Monitor mode allows you to continually view the present 
contents of the FST structure in the device as it is modified. Trace mode 
allows you to examine execution of an FST one step at a time for 
debugging purposes.  

B.1.20 Troubleshooting an FST 
An execution error, which occurs when the FST references a Point 
Number that has been removed or changed, will stop an FST.  

If a compile error occurs during the compile process (Build > 
Compile), the Output field lists the error type and the cell in question 
turns red. Execution errors are caused by changes in the FloBoss 
configuration after the download of an FST. This may include removal 
of I/O or other logical points the FST uses. 

In Monitor mode, the Run Flag Status (RF) indicates execution errors:  
RF Meaning 
0 Indicates the FST is not running. 
1 Indicates the FST is running. 

5 Indicates the FST has shut down due to an invalid point reference 
(usually an out-of-place or unexpected I/O). 

8 Indicates the FST Editor has initiated Trace mode. 
 
When an FST fails (as indicated by an RF value of 5), you can view at 
which Instruction Pointer (IP) the FST failed. 

B.2 FST Monitor Mode 
When on-line, use the FST Monitor menu to select which FST to 
monitor; turn Trace mode on and off; close the FST; pause or resume an 
FST; monitor registers, timers, miscellaneous registers, messages; or to 
compare flag options. 



ROCLINK 800 User Manual (FB107) 

B-12 FST Editor Issued Jan-08 

To start Monitor mode to display the selected FST, select the desired 
FST from the Monitor menu while on-line with the FloBoss or click the 
Monitor button from within the open workspace to monitor that FST. 
You can edit FST fields located on the right side of the Monitor screen 
by highlighting the field, typing the value, and pressing Enter. The new 
value is written to the FST and read back on the next update. 

The Help Status Line at the top of the Monitor indicates the status of the 
Monitor and Trace Modes. 

The Parameter and Data fields include:  

Field Description 
CF Compare Flag, an 8-bit integer representing the 

numbers 0 through 255. Often referred to as the 
Signal Value Discrete (SVD).  

CF Bny The Compare Flag displays as both the integer value 
and the binary value (bit 7 to the left and bit 0 to the 
right).  

RF Run Flag. Valid values are:  

 0 Indicates the FST is not running. 
 1 Indicates the FST is running. 
 5 Indicates FST has shut down due to an invalid 

point reference (usually an out-of-place or 
unexpected I/O). 

 8 Indicates the FST Editor has initiated Trace 
mode. 

 When an FST fails (as indicated by an RF value of 
5), you can view at which Instruction Pointer (IP) the 
FST failed. 

IP Instruction Pointer. Indicates the storage location in 
the FST of the next function to be executed. One 
storage location is used for each byte that stores the 
function. 

Size The number of bytes reserved for the FST program 
in bytes. Equivalent to the end pointer value minus 
the start pointer value. 

Brk The delay, in 100 millisecond intervals, between the 
execution of successive FST Commands or 
functions.  

RR The Results Register or accumulator, sometimes 
referred to as the Signal Value Analog (SVA), is a 
floating-point value passed between functions or 
FSTs.  

R1 through R10 Ten floating-point registers for each FST. The 
floating-point registers are used for global storage, 
and register contents can be called into any of the 
FSTs configured for a FloBoss. 

Timer 1 through 
Timer 4 

Four timers. When set greater than “0”, they 
decrement by “1” every 100 milliseconds. A timer can 
be set using the Set Timer (ST) Command or by 
saving the RR (Results Register) directly to the timer 
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Field Description 
parameter using the SAV Command. The Check 
Timer (CT) Command is used to compare the timer 
to “0”. When greater than “0”, it branches to the 
desired LABEL. 

MSG1 Character field for storing a message.  
MSG2 Not used by the FST. A value can be written to 

MSG2 using the FST Registers point or a ROC 
Display field and viewed while monitoring or tracing 
the FST.  

MSG Data Displays any values associated with MSG1.  
MISC 1 through  
MISC 4 

Single-byte registers that can be written to and the 
value can be used by the FST. Valid value is 0 to 
255.  

 

Table B-7. Monitor and Trace Mode Keystrokes 

Key Action Key Action 
↑ Move cursor to the cell above it. End Move cursor to the right-most cell. 

↓ Move cursor to the cell below it. F1 Help. 
Ctrl + End Display last entry in Workspace. F6 Execute current FST command. 

Ctrl + Home Display beginning of Workspace. Home Move cursor to the left-most cell. 
Page Down Display next page of Workspace. Page Up Display previous page of Workspace.

B.3 FST Trace Mode 
In Trace mode, you can view at which Instruction Pointer (IP) the FST 
failed. Print the FST to assist in troubleshooting. 

When on-line, the FST Editor uses a Trace mechanism that provides the 
ability to debug FST program logic. Trace executes the FST function 
indicated by the Instruction Pointer (IP), moves the Instruction Pointer 
to the next FST function to be executed, and then stops. You are given 
the opportunity to examine the results of the FST function and 
determine the next FST function to be executed. The location of the 
action depends on the nature of the command. The action may be traced 
to the history log, I/O value, Point Numbers, softpoint, and so on. 

The command executed is determined by comparing the Instruction 
Pointer (IP) shown on the Monitor screen to a list of all Instruction 
Pointers and their corresponding commands. Trace thereby verifies 
proper execution and sequencing of the FST functions. 

Note:  Before entering Trace mode, print out an Instruction Pointer 
listing of the FST. 

After entering Trace mode from a newly compiled FST, the FST starts 
at the first STEP. After entering Trace mode from an executing FST, the 
FST starts at the STEP being executed.  
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Note:  When you attempt to Trace an FST that contains WT, BRK, ST, 
or CT commands, a pause in the sequencing can occur until the 
command conditions are met. 

Other Trace commands include: 
 Select Monitor > Trace On to turn on Trace mode. 
 Select Monitor > Pause to stop the FST at the current command. 
 Select Monitor > Resume to start the FST at the current command. 
 Select Monitor > Trace Off to turn off Trace mode. 
 Select Monitor > Next Step to turn off Trace mode. 

B.4 FST Command Library 
Commands are identified by a name that consists of one or more 
characters or mathematical symbols. In the FST Editor, select the CMD 
field and perform one of the following: 
 Type the Command. 

 Click the  button.  
This opens a list of commands, the command names, and their 
descriptions (actions). See Table B-8, which describes the terms RR 
and CF used in the command descriptions (actions). 

Table B-9 presents each command name along with a brief description 
(action), the Arguments (ARGUMENT1 or ARGUMENT2) required, and 
the effect each operation has on the RR and CF. In the explanation of the 
operation, if RR or CF is not mentioned, then the current content is not 
affected and remains unchanged. In general, the CF is affected only by 
logical commands. 

Table B-8. FST Command Library Conventions 

Convention Description 
RR (in) The value or contents of the Results Register (RR), Signal Value Analog (SVA) prior to 

execution of the function (command). 
RR (out) Output value from Results Register (RR). 
CF (in) The value or contents of the Compare Flag (CF), Signal Value Discrete (SVD), prior to 

execution of a function (command). 
CF (out) The contents of the Compare Flag (CF), following execution of the function (command). 

Table B-9. FST Command Summary 

Category Command Action 
Math + RR = RR + ARGUMENT1 (add) 
 – RR = RR – ARGUMENT1 (subtract) 
 * RR = RR * ARGUMENT1 (multiply) 
 / RR = RR / ARGUMENT1 (divide) 
 ** RR = RR raised to power of ARGUMENT1 
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Category Command Action 
 ABS RR = Absolute value of RR 
 EXP RR = “e” (2.71828) raised to power of RR 
 INT RR = Integer value of RR 
 LOG RR = Log (base 10) of RR 
 LN RR = Natural Log of RR 
 SQR RR = Square root of RR 
 P3 RR = 3rd-order polynomial (R1, R2, R3, R4) 
Logical NOT SVD = NOT SVD (0 ≥ 1; > 0 ≥ 0) 
 AND SVD = SVD AND ARGUMENT1 
 OR SVD = SVD OR ARGUMENT1 
 XOR SVD = SVD XOR ARGUMENT1 
Comparison == If RR = ARGUMENT1, go to ARGUMENT2 LABEL 
 != If RR <> ARGUMENT1, go to ARGUMENT2 LABEL 
 < If RR < ARGUMENT1, go to ARGUMENT2 LABEL 
 <= If RR <= ARGUMENT1, go to ARGUMENT2 LABEL 
 > If RR > ARGUMENT1, go to ARGUMENT2 LABEL 
 >= If RR >= ARGUMENT1, go to ARGUMENT2 LABEL 
Time ST Set Timer # ARGUMENT1 to ARGUMENT2 100 mSec intervals 
 CT If Timer # ARGUMENT1 > 0, go to LABEL ARGUMENT2 
 WT Suspend FST execution for ARGUMENT1 sec 
 DWK RR = Day of Week (1=Sunday, 7=Saturday) 
 MND RR = Minutes since midnight 
Control AO Set AO# ARGUMENT1 output = ARGUMENT2 EUs 
 DO Set DO# ARGUMENT1 status = ARGUMENT2 
 TDO Force discrete output Recalculation 
Database VAL RR = Value specified in ARGUMENT1 
 SAV Write RR to variable specified in ARGUMENT1 
 RDB Read History Value into RR 
 WDB Write RR Value to History 
 WTM Write Current Time to History 
 DHV Read Daily History Value into RR 
 DHT Read Daily History Time Stamp into RR 
 PHV Read Periodic History Value into RR 
 PHT Read Periodic History Time Stamp into 
 MHV Read Minute History Value into RR 
 DIS Read Starting Daily History Index into RR 
 DIN Read Number of Daily History Indexes into RR 
 PIS Read Starting Periodic History Index into RR 
 PIN Read Number of Periodic History Indexes into RR 
 GTE Extract Time Element from Time Stamp into RR 
Miscellaneous GO Jump to STEP pointed to by ARGUMENT1 LABEL 
 MSG MSG String #1 = ARG1; MSG Data = ARG2 
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Category Command Action 
 END End of FST...restart at beginning 
 BRK Delay ARGUMENT1 100 mSec intervals  
 ALM Log 10-character message and a current value 
 EVT Log 10-character message and a current value 

B.4.1 FST Control-Related Commands 
Use analog output (AO), discrete output (DO), and Timed Duration 
Output (TDO) control-related commands to control outputs.  

Table B-10. FST Control-Related Commands 

Name Description Arguments Results 
AO Analog output. Sets the analog output 

point EUs to the argument value. If the 
analog output is in Manual, no output is 
sent. 

1. Output: AO Point 
Database Value 

2. Input: Database or 
Constant Value 

AO Output (ARG1) = ARG2 
 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

DO Discrete output. Sets the discrete output 
point status to the argument value. If the 
discrete output is in Manual, no output is 
sent. 

1. Output: DO Point 
Database Value 

2. Input: Database or 
Constant Value 

DO Output (ARG1) = ARG2 
 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

 

Note:  To trigger outputs, use the corresponding output command (see 
Table B-9). These commands trigger the mechanism that changes 
the output value. 

The analog output (AO) command sends the analog value specified in 
ARGUMENT2 to the analog Point Number specified in ARGUMENT1. 
The analog value is not sent if the analog Point Number is in Manual 
Mode. The check for Manual Mode is included as a safety feature and 
permits the FST to continue operation if the device connected to the 
analog output is being serviced.  

If a PID loop is controlling the analog output, placing the PID loop into 
Manual Tracking Mode allows the FST to send a value to the output 
parameter of the PID. For other active PID modes, the FST and PID will 
be in conflict. 

FST Mathematical  
Commands 

The mathematical commands provide simple arithmetic or mathematical 
operations. Such operations include addition (+), subtraction (–), 
multiplication (*), division (/), raise to power (**), absolute value 
(ABS), “e” raised to a power (EXP), truncate to integer (INT), base 10 
logarithm (LOG), natural logarithm (LN), square root (SQR), and 3rd-
order polynomial (P3). 

Note:  No operation occurs with the LOG, LN, power (**), and SQR 
commands if the Results Register is less than or equal to zero.  

Table B-11. FST Mathematical Commands 
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Name Description Arguments Results 
+ Add value to RR(in) 1. Input: Database or 

Constant Value 
RR(out) = RR(in) + ARG1 
SVD(out) = SVD(in) 

– Subtract value from RR(in) 1. Input: Database or 
Constant Value 

RR(out) = RR(in):ARG1 
SVD(out) = SVD(in) 

* Multiply RR(in) by value 1. Input: Database or 
Constant Value 

RR(out) = RR(in) * ARG1 
SVD(out) = SVD(in) 

/ Divide RR(in) by value 1. Database or Constant 
Value 

If ARG1 = 0.0: 
RR(out) = RR(in), SVD(out) = SVD(in) 

   Otherwise:  
RR(out) = RR(in) / ARG1 

** Raise RR(in) to a power 1. Input: Database or 
Constant Value 

RR(out) = RR(in) ** ARG1 

ABS Absolute Value of RR(in) None RR(out) = |RR(in)| 
SVD(out) = SVD(in) 

EXP “e” to the power of RR(in) None RR(out) = e ** RR(in) 
SVD(out) = SVD(in) 

INT Integer part of RR(in) None RR(out) = (int) RR(in) 
SVD(out) = SVD(in) 

LOG Logarithm (base 10) of 
RR(in) 

None If RR(in) > 0.0: 
RR(out) = LOG[RR(in)], SVD(out) = 
SVD(in) 
Otherwise: 
RR(out) = RR(in), SVD(out) = SVD(in) 

LN Natural Logarithm of 
RR(in) 

None If RR(in) > 0.0: 
RR(out) = LN[RR(in)], 
SVD(out) = SVD(in) 
Otherwise: 
RR(out) = RR(in), 
SVD(out) = SVD(in) 

SQR Square Root of RR(in) None If RR(in) >= 0.0: 
RR(out) = SQRT[RR(in)], 
SVD(out) = SVD(in) 
Otherwise: 
RR(out) = RR(in), 
SVD(out) = SVD(in) 

P3 3rd-order Polynomial None RR(out) = [reg1 * (RR(in) ** 3)] 
+ [reg2 * [RR(in) ** 2)] 
+ [reg3 * [RR(in) ** 1)] 
+ reg4 
where reg1 through reg4 are the current 
constant values of Register 1 through 
Register 4 of the respective FST 
SVD(out) = SVD(in) 

 

FST Logical  
Commands 

You can store a discrete value called the Signal Value Discrete (SVD) 
in the Compare Flag (CF). The SVD is stored as an 8-bit byte.  The CF 
is true whenever non-zero, and the CF is false when zero. 



ROCLINK 800 User Manual (FB107) 

B-18 FST Editor Issued Jan-08 

Logical commands operate upon the Compare Flag (CF). Prior to 
execution of a logical command, the CF must be loaded with an 8-bit 
value by using the SAV command. 

The bit-wise logical commands (AND, OR, NOT, and XOR) apply 
Boolean operations on two 8-bit integers, bit-by-bit. The two 8-bit 
integers are the CF and the value defined by ARGUMENT1 of the 
logical command. Note that this value is then converted by the software 
into an 8-bit unsigned integer. This value is used as a binary number 8 
bits long as described next. 

Each bit is weighted as a power of two, and the bit position determines 
which power of two. The bit, either 0 or 1, is multiplied by the 
respective bit weight. The resulting binary number is read from right to 
left, with the right-most bit representing bit 0, and the left-most bit 
representing bit 7. 

For example, the integer 42 is equivalent to the binary number 
00101010 as shown next, where bit 0 is the right-most bit: 

Bit Binary # * Weight = 
Bit 7 = 0 * 27 = 0 * 128 = 0 
Bit 6 = 0 * 26 = 0 * 64 = 0 
Bit 5 = 1 * 25 = 1 * 32 = 32 
Bit 4 = 0 * 24 = 0 * 16 = 0 
Bit 3 = 1 * 23 = 1 * 8 = 8 
Bit 2 = 0 * 22 = 0 * 4 = 0 
Bit 1 = 1 * 21 = 1 * 2 = 2 
Bit 0 = 0 * 20 = 0 * 1 = 0 

Total = 42 

Table B-12. FST Logical Commands 

Name Description Arguments Results 
NOT Logical NOT of SVD(in) None If SVD(in) > 0, SVD(out) = 0 

Otherwise: SVD(out) = 1 
RR(out) = RR(in) 

AND Logical AND ARG1 with SVD(in) 1. Input: Database or Constant 
Value 

RR(out) = RR(in), 

RR(out) = RR(in), OR Logical OR ARG1 with SVD(in) 1. Input: Database or Constant 
Value SVD(out) = [SVD(in) OR ARG1] 

RR(out) = RR(in), XOR Logical XOR ARG1 with SVD(in) 1. Input: Database or Constant 
Value SVD(out) = [SVD(in) XOR ARG1]

 

FST Comparison  
Commands 

Use comparison commands to compare values. Comparison commands 
conditionally compare two values, and branch to a different sequence of 
commands if the comparison is determined to be true. Otherwise, if the 
comparison is determined to be false, no branching occurs and the next 
command in sequence is executed. Comparison commands test values 
for equivalence (==), non-equivalence (!=), less than (<), less than or 
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equal to (<=), greater than (>) , and greater than or equal to (>=). 

Table B-13. FST Comparison Commands 

Name Description Arguments Results 
== Test If RR(in) equals ARG1. 

Note that this command performs in a 
bit-wise fashion, so two floating Point 
Numbers displayed as equal may not 
match. 

1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) = ARG1, Goto ARG2 
Otherwise: continue to next 
command 
SVD(out) = SVD(in) 

!= Test If RR(in) Not Equal to 
ARG1. 

1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) != ARG1, Goto ARG2 
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

< Test If RR(in) less than ARG1. 1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) < ARG1, Go to ARG2 
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

<= Test If RR(in) less than or equal 
to ARG1. 

1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) <= ARG1, Go to ARG2  
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

> Test If RR(in) greater than 
ARG1. 

1. Input: Database or Constant 
Value 
2. LABEL  

If RR(in) > ARG1, Go to ARG2 
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

>= Test if RR(in) greater than or 
equal to ARG1. 

1. Input: Database or Constant 
Value 
2. LABEL 

If RR(in) >= ARG1, go to ARG2  
Otherwise: continue to next 
command 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

 

FST Time-Related  
Commands 

Use time-related commands (FST Timers) to implement simple time-
related operations, such as setting Timers, checking Timers, 
determining if Timers have elapsed, wait time before continuing, and 
imposing a delay upon each command executed.  

Timers are used to branch the FST to a specific Label after a specified 
period of time following an action. Up to four Timers are available for 
use in an FST and each Timer has a time interval of 100 milliseconds. 
Each FST Timer decreases by 1 interval if the Timer value is greater 
than 0.  

Command Description 
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Command Description 
Set Timer (ST) The ST command sets any one of the four available 

Timers for any of the available FSTs. ARGUMENT1 
specifies the number of the Timer to set and 
ARGUMENT2 specifies the number of intervals to 
which the Timer is set. 

Check Timer (CT) When executing a loop repeatedly in an FST, it is 
recommended a timer (CT) be included so the loop 
executes only once every time interval. This prevents 
the loop from executing several times within the 
allotted task period, eliminating unnecessary 
calculations that could deprive time from other tasks. 

Wait (WT) The Wait (WT) command imposes a delay, entered 
in seconds and tenths of seconds, before executing 
the next command. For example, entering a value of 
0.1 implies a 100-millisecond delay and a value of 
1.0 implies a one-second delay.  

Day of Week (DWK) 
and Minutes Since 
Midnight (MND) 

These commands are written to the Results Register. 
For DWK, 1=Sunday through 7=Saturday. 

 

Table B-14. FST Time-Related Commands 

Name Description Arguments Results 
ST Set Timer for specified FST with 

value in 100 mSec intervals.  
1. Output: FST Point 
Database Value 
2. Input: Database or 

Constant Value 

FST Timer (ARG1) = ARG2 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

CT Check Timer for specified FST with 
value in 100 mSec intervals.  

1. Input: FST Point Database 
Value 
2. LABEL 

If FST Timer (ARG1) = 0, 
continue to next command.  
Otherwise, Goto ARG2. 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

WT Wait – suspend FST until specified 
number of seconds (ARG1) have 
elapsed. The number of seconds 
can be from 0.1 to 999,999.  

1. Input: Database or 
Constant Value 

Delay ARG1 seconds 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

DWK Day of Week – sets RR (out) to the 
day of the week (1=Sunday, 
7=Saturday). 
Note:  The DWK function requires 

that you correctly set the real-
time clock.  

None RR(out) = Day of Week 
SVD(out) = SVD(in) 

MND Minutes Since Midnight – sets RR 
(out) to the number of minutes past 
midnight. 

None RR(out) = Minutes 
SVD(out) = SVD(in) 

 

FST Miscellaneous 
Commands 

Use the miscellaneous commands to move around FSTs and end FSTs. 
Miscellaneous commands provide operations, such as an unconditional 
go to (GO), message to local display panel (MSG), alarms (ALM), and 
event (EVT) generation, end of the FST (END), and delay (BRK). 
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Command Description 
GO Executes an unconditional branch to the LABEL in 

ARGUMENT1. Branching can direct the FST to a 
step before or after the current step.  

Message Provides a 30-character message and value for 
viewing on the local display panel.  

Break Imposes a delay (Break period), in 100-millisecond 
intervals, before executing the next command. Once 
the break period is set to a value other than zero, a 
delay in 100-millisecond or 1 second intervals occurs 
between the executions of each subsequent 
command. 

End Completes execution of the FST and waits for the 
next FST execution cycle before returning to the first 
STEP of the FST. The END command can only be 
used once in an FST. If omitted, End is appended to 
the FST by the FST Editor at compile time following 
the first empty Command field. 

Alarm and Event Log Log a 10-character message and the current value of 
the selected parameter to the respective log.  

 

Table B-15. FST Miscellaneous Commands 

Name Description Arguments Results 
GO Go to specified LABEL. 1. LABEL Goto ARG1 

RR(out) = RR(in) 
SVD(out) = SVD(in) 

BRK Break delays execution of each 
command after this one for the 
number of 100 millisecond intervals 
defined by ARGUMENT1. 

1. Input: Database or Constant 
Value 

FST break time = ARG1 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

END End of FST returns to first 
command. 

None Execute FST starting with first 
command. 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

MSG LCD Message sends message 
(ARGUMENT1) and value 
(ARGUMENT2) to local display 
panel. One 30 character message 
can be sent by each FST as shown 
next: 
 
xxxxxxxxxxxxxxxxxx 
xxxxxxxx ARG2 VAL 
yyyyyyyy zzzzz.zz 
SCAN NEXT PREV MENU 
xxxx ...message 
yyyy ...FST Tag name 
zzzz ...ARGUMENT2 value 

1. Input: Message 
2. Input: Database or Constant 
Value 

FST Message String(ARG1) 
FST Message Value(ARG2) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

ALM Log Alarm records message 1 .Input: Message Log Alarm(ARG1, ARG2) 
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Name Description Arguments Results 
(ARGUMENT1) and value 
(ARGUMENT2) in the Alarm Log. 
Only the first 10 characters of the 
30 character messages are used. 

2. Input: Database or Constant 
Value 

RR(out) = RR(in) 
SVD(out) = SVD(in) 

EVT Log Event records message 
(ARGUMENT1) and value 
(ARGUMENT2) in the Event Log. 
Only the first 10 characters of the 
30 character message are used.  

1. Input: Message 
2. Input: Database or Constant 
Value 

Log Event(ARG1,ARG2) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

Note: The ALM and EVT functions can quickly overfill the allotted log space of alarms and events. It is 
important to assure that these two functions do not operate continuously. 

 

FST Database 
Commands 

Database commands provide access to the configuration and historical 
databases. Operations include reading and writing configuration 
parameters and reading, writing, storing values from historical 
databases, and time stamping values to a History Point. 

 

Command Description 
VAL Loads the Results Register (RR) with the value 

defined in ARGUMENT1. ARGUMENT1 can be a 
constant or any database parameter available to the 
FST. The value defined in ARGUMENT1 is 
converted to floating point data type and written to 
the Results Register. 

SAV Writes the Results Register (RR) value to any 
database parameter available to the FST as defined 
in ARGUMENT1.  

WDB, WTM, and RDB These historical database commands, Write to 
Historical Database (WDB), Write Time to Historical 
Database (WTM), and Read Historical Database 
(RDB), allow you to establish a non-periodic history 
database (one that has no specific time interval), a 
periodic history database (one that has a specific 
time interval), or a storage array for data (similar to a 
softpoint).  
For the FST historical database commands to work, 
a History Point has to be configured correctly for a 
FST History Point as either FST Time Archive Type 
or FST Data Archive Type. Refer to Section B.4.2, 
Defining a FST History Point.  
The FST for a History Point uses one of the historical 
database commands and two Arguments. 
ARGUMENT1 contains the history database point 
number. ARGUMENT1 can be a constant or a 
parameter with a value between 1 through 87. 

ARGUMENT2 Provides an index or pointer to the history storage 
array. The history storage array holds entries taken 
at either set intervals (typically daily, hourly, and 
each minute) or user-configurable intervals. For 
information on the intervals and number of entries, 
refer to the history database specifications instruction 
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Command Description 
manual. ARGUMENT2 should be a Soft point or FST 
register. The history point defined by ARGUMENT1 
will be logged at the index location defined by 
ARGUMENT2. 

 

Table B-16. FST Database Commands 

Name Description Arguments Results 
VAL Load RR sets the RR(out) to the argument 

value. 
1. Input: Database 

or Constant 
Value 

RR(out) = ARG1 
SVD(out) = SVD(in) 

SAV Store RR sets the argument to the RR(in). 1. Output: 
Database Value

ARG1 = RR(in) 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

RDB Read Historical Database sets the RR(out) 
to the historical database value of the 
specified database point (ARGUMENT1) 
and the specified pointer (ARGUMENT2) 
to the historical database value. Applies to 
historical database points defined for the 
FST only.  
If ARGUMENT2* is a floating database 
value (for example: @FST1, FST SEQ# 1, 
R8), the command increments 
ARGUMENT2 to the next historical 
database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
Note:  Each ARGUMENT2 must be 

unique.   

1. Input: Database 
or Constant 
Value 

2. Output: 
Database or 
Constant Value 

For FST History Point: 
RR(out) = History Value(ARG1,ARG2)
For floating database value ARG2: 
If ARG1 >= No. of archived periods 
(ARG1), then ARG2 = 0 
Otherwise, ARG2 = ARG2 + 1 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

WDB Write To Historical Database sets the 
RR(in) to the value of the database point 
(ARGUMENT1) and the pointer 
(ARGUMENT2). Applies to historical 
database points defined for the FST only.  
If ARGUMENT2* is a floating database 
value (for example: @FST1, FST SEQ# 1, 
R8), the command increments 
ARGUMENT2 to the next historical 
database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
Note:  Each ARGUMENT2 must be 

unique. 

1. Output: 
Database or 
Constant Value

2. Output: 
Database or 
Constant Value

For FST History Point: 
History Value (ARG1, ARG2) = 
RR(in).  
For floating database value ARG2: 
If ARG2 >= No. of archived periods 
(ARG1), then  
ARG2 = 0. 
Otherwise, ARG2 = ARG2 + 1. 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

WTM Write Time To Historical Database sets the 
value of the database point 
(ARGUMENT1) and the pointer 
(ARGUMENT2) to the historical database 
time string with either minutes or seconds 
resolution. The time format for minute's 
resolution is [min,hr,day,mon] and for 

1. Output: 
Database or 
Constant Value

2. Output: 
Database or 
Constant Value

For FST History Point: 
If minute resolution, then 
History Value (ARG1, ARG2 = minute 
format.  
Otherwise: History Value 
(ARG1,ARG2) = second format.  
For floating database value ARG2: 
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Name Description Arguments Results 
seconds resolution is [sec,min,hr,day]. 
Applies to historical database points 
defined for the FST only. 
If ARGUMENT2* is a floating database 
value (for example: @FST1, FST SEQ# 1, 
R8), the command increments 
ARGUMENT2 to the next historical 
database value and sets it to 0 when the 
number of archived historical periods are 
exceeded. Otherwise, no effect occurs to 
ARGUMENT2. 
Note:  Each ARGUMENT2 must be 

unique. 

If ARG2 >= number of archived 
periods (ARG1), then  
ARG2 = 0.  
Otherwise: ARG2 = ARG2 + 1. 
For all other cases: 
RR(out) = RR(in) 
SVD(out) = SVD(in) 

 

B.4.2 Defining a FST History Point 
When defining history database points for WDB, WTM, and RDB, you 
must define at least one History Point as an FST Time type (minute or 
second) to provide a time stamp for the values logged. The time stamps 
represent what time each portion of the accumulated data was logged. 

To define an FST History Point: 

1. Select Configure > History Points. 

2. Select the desired History Point. 

3. Click the Archive Type TLP button and select FST Time or FST 
Data. 

4. Click the Archive Point TLP button and select any TLP, such as 
FST Register 2 to contain the data or time stamp. The Archive Point 
selection is ignored by the FST. 

5. Click OK. 

Historical 
Commands 

The FST for a History Point uses one of the historical database 
commands and two Arguments. ARGUMENT1 typically contains the 
history database History Point number with a value between 1 through 
200. 

ARGUMENT2 is the History Index or database pointer to the history 
storage array. The history storage array holds entries taken at either set 
intervals (typically daily, hourly, and each minute) or user-configurable 
intervals. 

For the DHV, DHT, PHV, PHT, and MHV commands, select the 
History Segment and the corresponding History Point that you desire to 
log in Argument 1. In Argument 2, select either a database point or a 
constant value, which is the actual History Index where the data resides 
in the historical database. 

The Minute History Value (MHV) History Index is the same as the 
minute of the hour. Read the clock’s minutes to get the last History 
Index value. For example, if it is 8:10 then the History Index is 10. 
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For the Extract Time Element (GTE) command, select the database 
point or a constant value, which is the actual History Index value where 
the data resides in the historical database. In Argument 2, select the 
Time Element to log the exact time of the database point or History 
Index value. The GTE command is used to extract the time element 
from the time stamp received back from the CHT and PHT commands. 

For DIS, DIN, PIS, and PIN commands, select the History Segment 
and the corresponding History Point that you desire to log in Argument 
1. In Argument 2, select the Month and Date on which to log the 
History Index value. 

To acquire the Daily History Value (DHV), perform a Starting Daily 
Index (DIS) command to locate the starting History Index value for a 
specific day. Using the DIS History Index value, use the DHV 
command to locate the Daily History Value. 

To find specific data in history, such as the data entered at 9:00 AM 
yesterday, first use the Starting Periodic Index (PIS) command to find 
the starting History Index value for yesterday’s date and then count 
forward nine to acquire the History Index value for 9:00 AM. Use this 
new History Index with the Periodic History Value (PHV) command to 
locate the data.  

Table B-17. FST Historical Commands 

Name Description Arguments Results 
DHV Daily History Value 1. Input: History Segment, History Point

2. Input: DB Point or Constant (History 
Index) 

Stores value in RR.  
Halts on invalid History Index. 

DHT Daily History Time 
Stamp 

1. Input: History Segment, History Point
2. Input: DB Point or Constant (History 
Index) 

Stores value in RR. 
Halts on invalid History Index. 

PHV Periodic History Value 1. Input: History Segment, History Point
2. Input: DB Point or Constant (History 
Index) 

Stores value in RR. 
Halts on invalid History Index. 

PHT Periodic History Time 
Stamp 

1. Input: History Segment, History Point
2. Input: DB Point or Constant (History 
Index) 

Stores value in RR. 
Halts on invalid History Index. 

MHV Minute History Value 1. Input: History Segment, History Point
2. Input: DB Point or Constant (History 
Index) 

Stores value in RR. 
Halts on invalid History Index. 

DIS Starting Daily Index 1. Input: History Segment, History Point
2. Input: Month/Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

DIN Number of Daily 
Indexes 

1. Input: History Segment, History Point
2. Input: Month / Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

PIS Starting Periodic Index 1. Input: History Segment, History Point
2. Input: Month / Day 

Stores value in RR. 
Returns –1 if Month/Day not 
found. 

PIN Number of Periodic 1. Input: History Segment, History Point Stores value in RR. 
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Name Description Arguments Results 
Indexes 2. Input: Month / Day Returns –1 if Month/Day not 

found. 
GTE Extract Time Element 1. Input: DB Point or Constant (History 

Index) (Time in Seconds since 
1/1/1970) 
2. Input: Time Element 

Stores value in RR. 
Valid Time Elements: 
0 – Month 
1 – Day 
2 – Year 
3 – Hour 
4 – Minute 
5 – Second 

 

B.5 Example FST  
This example FST shows how to configure history and then write an 
FST to submit data to the historical database.  

1. Access the History Setup screen (Configure > History Points). The 
History Setup screen displays.   

 
Figure B-3. History Setup 

2. Add two new definitions, one for point 9 (FST Data at FST 1, R1) 
and one for point 10 (FST Time – Second at FST 1, R2). You use 
these points when you define the FST.  
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3. Access the FST Editor (Utilities > FST Editor). A blank FST 
Editor screen displays.  

 
Figure B-4. Blank FST Editor 

4. Complete steps 0 through 4 with the commands and arguments as 
shown below:  

 
Figure B-5. Sample FST 
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a. Get the value (VAL) from softpoint 1, data 1, and save it to the 
first results register.  

b. Write the value saved in the Results Register to the historical 
database (WDB), placing it at point 9 (FST Data at FST 1, R1, 
as defined on the History Setup screen in Figure B-3). The 
system also creates an historical index for point 9 in FST1.  

Note:  For steps b and c, you must use the number of the point 
as Argument 1.  

c. Write the current time (WTM) to the historical point 10 (FST 
Time – Second at FST 1, R2, as defined on the History Setup 
screen). The system also creates an historical index for point 10 
in FST1.  

Note:  It is possible (and very likely) that the historical time 
intervals will not match the same intervals the FST uses 
when it records historical data. This step gives the 
periodic history report a time stamp when the FST 
records data. 

d. Suspend the FST execution (WT) for 5 seconds.  

e. Stop the FST execution (END) and restart at step 0.  

5. Click the Compile FST button ( ) on the FST Editor menu bar. 
The FST Editor compiles the FST and determines whether it 
contains any errors in the area below the FST:   

 
Figure B-6. Compiled FST 
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6. Click the Save to .FST button ( ) on the FST Editor menu bar. A 
Save As dialog box displays.   

 
Figure B-7. Save As 

7. Use this screen to name and save your FST. When you click Save, 
the FST Editor displays.   

Finally, you have to download the FST to the FB107 to make it active.   

8. Click the Download button ( ) on the FST Editor menu bar. An 
FST Details dialog box displays.  

 
Figure B-8. FST Details 

9. Complete at very least the Description field, providing a brief (up to 
40 characters) description of the FST. 

Note:  If you anticipate developing several versions of an FST, 
complete the Version field so you can easily tell one version 
from another.  
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10. Click OK. When the download completes, ROCLINK 800 prompts 
you to start the FST.  

 
Figure B-9. FST Download completed 

At this point the FST is stored in one of the four FST “slots” in the 
FB107. Click Yes to start the FST or No to return to the FST Editor.   
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Remote Automation Solutions 
Marshalltown, IA 50158 U.S.A. 
Houston, TX 77065 U.S.A. 
Pickering, North Yorkshire UK Y018 7JA 
Website: www.EmersonProcess.com/Remote 




